VS:SetConstrain

From Vectorworks Developer
Revision as of 14:37, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetConstrain sets the active drawing constraints for the document. Each constraint is represented by an ASCII character identifier; these characters are assembled into a string which determines the constraints to be activated. VectorWorks Constraint Identifiers

Constraint Identifier
Snap To Grid A
Snap To Objects Q
Constrain Angle S
Snap Intersection W
Smart Points D
Snap To Distance E
Smart Edge F
Constrain Tangent R
PROCEDURE SetConstrain(
str :STRING);
def vs.SetConstrain(str):
    return None

Parameters

str STRING Constraint constant string.

Example

VectorScript

SetConstrain('QD');

{activates the snap objects and smart point constraints and deactivates the others}

Python


Version

Availability: from All Versions