VS:SetComponentWidth

From Vectorworks Developer
Revision as of 20:10, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the width of a component in an object.

FUNCTION SetComponentWidth(
obj :HANDLE;
componentIndex :INTEGER;
width :REAL) : BOOLEAN;
def vs.SetComponentWidth(obj, componentIndex, width):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
width REAL The width of the component.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:GetComponentWidth

VS Functions: [[VS:GetComponentWidth]]