VS:SetComponentWallTopOffset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(Shorten OBJECT, reserved word)
 
(One intermediate revision by one other user not shown)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION SetComponentWallTopOffset(object:HANDLE; componentIndex:INTEGER; offsetFromWallTop:REAL) : BOOLEAN;
FUNCTION SetComponentWallTopOffset(obj:HANDLE; componentIndex:INTEGER; offsetFromWallTop:REAL) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.SetComponentWallTopOffset(object, componentIndex, offsetFromWallTop):
def vs.SetComponentWallTopOffset(obj, componentIndex, offsetFromWallTop):
     return BOOLEAN
     return BOOLEAN
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.

Latest revision as of 20:10, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the offset from wall top of a component in an object.

FUNCTION SetComponentWallTopOffset(
obj :HANDLE;
componentIndex :INTEGER;
offsetFromWallTop :REAL) : BOOLEAN;
def vs.SetComponentWallTopOffset(obj, componentIndex, offsetFromWallTop):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
offsetFromWallTop REAL The offset from wall top of the component.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:GetComponentWallTopOffset

VS Functions: [[VS:GetComponentWallTopOffset]]