VS:SetComponentUsePenClassAttr

From Vectorworks Developer
Revision as of 20:09, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the use class attributes flags of the pens of a component in an object.

FUNCTION SetComponentUsePenClassAttr(
obj :HANDLE;
componentIndex :INTEGER;
useLeftPenClassAttributes :BOOLEAN;
useRightPenClassAttributes :BOOLEAN) : BOOLEAN;
def vs.SetComponentUsePenClassAttr(obj, componentIndex, useLeftPenClassAttributes, useRightPenClassAttributes):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
useLeftPenClassAttributes BOOLEAN Whether or not the component will use class attributes for its left pen.
useRightPenClassAttributes BOOLEAN Whether or not the component will use class attributes for its right pen.

Remarks

CJG 3-23-07

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:GetComponentUsePenClassAttr

VS Functions: [[VS:GetComponentUsePenClassAttr]]