VS:SetComponentUsePenClassAttr: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION SetComponentUsePenClassAttr(object:HANDLE; componentIndex:INTEGER; useLeftPenClassAttributes:BOOLEAN; useRightPenClassAttributes:BOOLEAN) : BOOLEAN;
FUNCTION SetComponentUsePenClassAttr(obj:HANDLE; componentIndex:INTEGER; useLeftPenClassAttributes:BOOLEAN; useRightPenClassAttributes:BOOLEAN) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.SetComponentUsePenClassAttr(object, componentIndex, useLeftPenClassAttributes, useRightPenClassAttributes):
def vs.SetComponentUsePenClassAttr(obj, componentIndex, useLeftPenClassAttributes, useRightPenClassAttributes):
     return BOOLEAN
     return BOOLEAN
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.

Latest revision as of 20:09, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the use class attributes flags of the pens of a component in an object.

FUNCTION SetComponentUsePenClassAttr(
obj :HANDLE;
componentIndex :INTEGER;
useLeftPenClassAttributes :BOOLEAN;
useRightPenClassAttributes :BOOLEAN) : BOOLEAN;
def vs.SetComponentUsePenClassAttr(obj, componentIndex, useLeftPenClassAttributes, useRightPenClassAttributes):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
useLeftPenClassAttributes BOOLEAN Whether or not the component will use class attributes for its left pen.
useRightPenClassAttributes BOOLEAN Whether or not the component will use class attributes for its right pen.

Remarks

CJG 3-23-07

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:GetComponentUsePenClassAttr

VS Functions: [[VS:GetComponentUsePenClassAttr]]