VS:SetComponentUseFillClassAttr

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the use fill class attributes flag of a component in an object.

FUNCTION SetComponentUseFillClassAttr(
obj :HANDLE;
componentIndex :INTEGER;
useFillClassAttributes :BOOLEAN) : BOOLEAN;
def vs.SetComponentUseFillClassAttr(obj, componentIndex, useFillClassAttributes):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
useFillClassAttributes BOOLEAN Whether or not the component will use class attributes for its fill.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:GetComponentUseFillClassAttr

VS Functions: [[VS:GetComponentUseFillClassAttr]]