VS:SetComponentTexture

From Vectorworks Developer
Revision as of 17:41, 16 September 2010 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the texture of a component in an object.

FUNCTION SetComponentTexture(
object :HANDLE;
componentIndex :INTEGER;
texture :LONGINT) : BOOLEAN;
def vs.SetComponentTexture(object, componentIndex, texture):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
texture LONGINT The ref number of the texture. 0 for no texture. -1 for class texture.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:GetComponentTexture

VS Functions: [[VS:GetComponentTexture]]