VS:SetComponentTexture: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:37, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the texture of a component in an object.

FUNCTION SetComponentTexture(
object :HANDLE;
componentIndex :INTEGER;
texture :LONGINT) : BOOLEAN;
def vs.SetComponentTexture(object, componentIndex, texture):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
texture LONGINT The ref number of the texture. 0 for no texture. -1 for class texture.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:GetComponentTexture

VS Functions: [[VS:GetComponentTexture]]