VS:SetComponentSize

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the width and height of the specified Layout Manager component in pixels.

Remark: Works in the dialog's setup handler. Can be used with AdjustComponentPixelPos.

FUNCTION SetComponentSize(
nDialogID :LONGINT;
nComponentID :LONGINT;
nWidthPixels :INTEGER;
nHeightPixels :INTEGER) : BOOLEAN;
def vs.SetComponentSize(nDialogID, nComponentID, nWidthPixels, nHeightPixels):
    return BOOLEAN

Parameters

nDialogID LONGINT
nComponentID LONGINT
nWidthPixels INTEGER
nHeightPixels INTEGER

Version

Availability: from VectorWorks13.0