VS:SetComponentSize: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Sets the width and height of the specified Layout Manager component.</desc>
Sets the width and height of the specified Layout Manager component in pixels.  
Remark: Works in the dialog's setup handler. Can be used with AdjustComponentPixelPos.
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 10:35, 16 May 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the width and height of the specified Layout Manager component in pixels.

Remark: Works in the dialog's setup handler. Can be used with AdjustComponentPixelPos.

FUNCTION SetComponentSize(
nDialogID :LONGINT;
nComponentID :LONGINT;
nWidthPixels :INTEGER;
nHeightPixels :INTEGER) : BOOLEAN;
def vs.SetComponentSize(nDialogID, nComponentID, nWidthPixels, nHeightPixels):
    return BOOLEAN

Parameters

nDialogID LONGINT
nComponentID LONGINT
nWidthPixels INTEGER
nHeightPixels INTEGER

Version

Availability: from VectorWorks13.0