VS:SetComponentPenWeights: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 14:37, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the left and right pen weights for a component in an object.

FUNCTION SetComponentPenWeights(
object :HANDLE;
componentIndex :INTEGER;
leftPenWeight :INTEGER;
rightPenWeight :INTEGER) : BOOLEAN;
def vs.SetComponentPenWeights(object, componentIndex, leftPenWeight, rightPenWeight):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenWeight INTEGER The pen weight of the component's left line.
rightPenWeight INTEGER The pen weight of the component's right line.

Remarks

VW2011: It seems that the right line doesn't get adjusted...

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:GetComponentPenWeights

VS Functions: [[VS:GetComponentPenWeights]]