VS:SetComponentPenStyles

From Vectorworks Developer
Revision as of 05:37, 3 February 2016 by CBM-c- (talk | contribs) (shorten 'object' (reserved word))
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the left and right pen styles for a component in an object.

FUNCTION SetComponentPenStyles(
obj :HANDLE;
componentIndex :INTEGER;
leftPenStyle :INTEGER;
rightPenStyle :INTEGER) : BOOLEAN;
def vs.SetComponentPenStyles(obj, componentIndex, leftPenStyle, rightPenStyle):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenStyle INTEGER The pen style of the component's left line. Positive values for patterns, negative values for dash styles.
rightPenStyle INTEGER The pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:GetComponentPenStyles

VS Functions: [[VS:GetComponentPenStyles]]