VS:SetComponentPenStyles: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (shorten 'object' (reserved word))
m (space missing)
 
Line 59: Line 59:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Latest revision as of 05:37, 3 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the left and right pen styles for a component in an object.

FUNCTION SetComponentPenStyles(
obj :HANDLE;
componentIndex :INTEGER;
leftPenStyle :INTEGER;
rightPenStyle :INTEGER) : BOOLEAN;
def vs.SetComponentPenStyles(obj, componentIndex, leftPenStyle, rightPenStyle):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenStyle INTEGER The pen style of the component's left line. Positive values for patterns, negative values for dash styles.
rightPenStyle INTEGER The pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:GetComponentPenStyles

VS Functions: [[VS:GetComponentPenStyles]]