VS:SetComponentPenStyles: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (space missing)
 
(2 intermediate revisions by 2 users not shown)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION SetComponentPenStyles(object:HANDLE; componentIndex:INTEGER; leftPenStyle:INTEGER; rightPenStyle:INTEGER) : BOOLEAN;
FUNCTION SetComponentPenStyles(obj:HANDLE; componentIndex:INTEGER; leftPenStyle:INTEGER; rightPenStyle:INTEGER) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.SetComponentPenStyles(object, componentIndex, leftPenStyle, rightPenStyle):
def vs.SetComponentPenStyles(obj, componentIndex, leftPenStyle, rightPenStyle):
     return BOOLEAN
     return BOOLEAN
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
Line 59: Line 59:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Latest revision as of 05:37, 3 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the left and right pen styles for a component in an object.

FUNCTION SetComponentPenStyles(
obj :HANDLE;
componentIndex :INTEGER;
leftPenStyle :INTEGER;
rightPenStyle :INTEGER) : BOOLEAN;
def vs.SetComponentPenStyles(obj, componentIndex, leftPenStyle, rightPenStyle):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenStyle INTEGER The pen style of the component's left line. Positive values for patterns, negative values for dash styles.
rightPenStyle INTEGER The pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:GetComponentPenStyles

VS Functions: [[VS:GetComponentPenStyles]]