VS:SetComponentPenColors

From Vectorworks Developer
Revision as of 16:43, 4 October 2010 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the colors of the pens of a component in an object.

FUNCTION SetComponentPenColors(
object :HANDLE;
componentIndex :INTEGER;
leftPenForeColor :INTEGER;
leftPenBackColor :INTEGER;
rightPenForeColor :INTEGER;
rightPenBackColor :INTEGER) : BOOLEAN;
def vs.SetComponentPenColors(object, componentIndex, leftPenForeColor, leftPenBackColor, rightPenForeColor, rightPenBackColor):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenForeColor INTEGER The fore color of the left pen.
leftPenBackColor INTEGER The back color of the left pen.
rightPenForeColor INTEGER The fore color of the right pen.
rightPenBackColor INTEGER The back color of the right pen.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:GetComponentPenColors

VS Functions: [[VS:GetComponentPenColors]]