VS:SetComponentPenColors: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION SetComponentPenColors(object:HANDLE; componentIndex:INTEGER; leftPenForeColor:INTEGER; leftPenBackColor:INTEGER; rightPenForeColor:INTEGER; rightPenBackColor:INTEGER) : BOOLEAN;
FUNCTION SetComponentPenColors(obj:HANDLE; componentIndex:INTEGER; leftPenForeColor:INTEGER; leftPenBackColor:INTEGER; rightPenForeColor:INTEGER; rightPenBackColor:INTEGER) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.SetComponentPenColors(object, componentIndex, leftPenForeColor, leftPenBackColor, rightPenForeColor, rightPenBackColor):
def vs.SetComponentPenColors(obj, componentIndex, leftPenForeColor, leftPenBackColor, rightPenForeColor, rightPenBackColor):
     return BOOLEAN
     return BOOLEAN
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.

Latest revision as of 20:08, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the colors of the pens of a component in an object.

FUNCTION SetComponentPenColors(
obj :HANDLE;
componentIndex :INTEGER;
leftPenForeColor :INTEGER;
leftPenBackColor :INTEGER;
rightPenForeColor :INTEGER;
rightPenBackColor :INTEGER) : BOOLEAN;
def vs.SetComponentPenColors(obj, componentIndex, leftPenForeColor, leftPenBackColor, rightPenForeColor, rightPenBackColor):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenForeColor INTEGER The fore color of the left pen.
leftPenBackColor INTEGER The back color of the left pen.
rightPenForeColor INTEGER The fore color of the right pen.
rightPenBackColor INTEGER The back color of the right pen.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:GetComponentPenColors

VS Functions: [[VS:GetComponentPenColors]]