VS:SetComponentMaterial

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the material of a component in an object.

FUNCTION SetComponentMaterial(
object :HANDLE;
componentIndex :INTEGER;
material :LONGINT) : BOOLEAN;
def vs.SetComponentMaterial(object, componentIndex, material):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
material LONGINT The material of the component.

Version

Availability: from Vectorworks 2021

See Also

VS Functions:

VS:GetComponentMaterial

VS Functions: [[VS:GetComponentMaterial]]