VS:SetComponentFill

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the fill of a component in an object.

FUNCTION SetComponentFill(
obj :HANDLE;
componentIndex :INTEGER;
fill :LONGINT) : BOOLEAN;
def vs.SetComponentFill(obj, componentIndex, fill):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
fill LONGINT The fill of the component. Positive values for patterns, negative object indexes for hatches.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:GetComponentFill

VS Functions: [[VS:GetComponentFill]]