VS:SetComponentFill: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:37, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the fill of a component in an object.

FUNCTION SetComponentFill(
object :HANDLE;
componentIndex :INTEGER;
fill :LONGINT) : BOOLEAN;
def vs.SetComponentFill(object, componentIndex, fill):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
fill LONGINT The fill of the component. Positive values for patterns, negative object indexes for hatches.

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:GetComponentFill

VS Functions: [[VS:GetComponentFill]]