VS:SetComponentFill: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION SetComponentFill(object:HANDLE; componentIndex:INTEGER; fill:LONGINT) : BOOLEAN;
FUNCTION SetComponentFill(obj:HANDLE; componentIndex:INTEGER; fill:LONGINT) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.SetComponentFill(object, componentIndex, fill):
def vs.SetComponentFill(obj, componentIndex, fill):
     return BOOLEAN
     return BOOLEAN
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
Line 54: Line 54:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Latest revision as of 20:05, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the fill of a component in an object.

FUNCTION SetComponentFill(
obj :HANDLE;
componentIndex :INTEGER;
fill :LONGINT) : BOOLEAN;
def vs.SetComponentFill(obj, componentIndex, fill):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
fill LONGINT The fill of the component. Positive values for patterns, negative object indexes for hatches.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:GetComponentFill

VS Functions: [[VS:GetComponentFill]]