VS:SetComponentClass: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION SetComponentClass(object:HANDLE; componentIndex:INTEGER; componentClass:LONGINT) : BOOLEAN;
FUNCTION SetComponentClass(obj:HANDLE; componentIndex:INTEGER; componentClass:LONGINT) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.SetComponentClass(object, componentIndex, componentClass):
def vs.SetComponentClass(obj, componentIndex, componentClass):
     return BOOLEAN
     return BOOLEAN
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.

Latest revision as of 20:05, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the class of a component in an object.

FUNCTION SetComponentClass(
obj :HANDLE;
componentIndex :INTEGER;
componentClass :LONGINT) : BOOLEAN;
def vs.SetComponentClass(obj, componentIndex, componentClass):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
componentClass LONGINT The class of the component.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:GetComponentClass

VS Functions: [[VS:GetComponentClass]]