VS:SetCompUseClassLPS: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 17:43, 16 September 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the use class pen style for left pen flag of a component in an object.

FUNCTION SetCompUseClassLPS(
object :HANDLE;
componentIndex :INTEGER;
useClassPenStyleForLeftPen :BOOLEAN) : BOOLEAN;
def vs.SetCompUseClassLPS(object, componentIndex, useClassPenStyleForLeftPen):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
useClassPenStyleForLeftPen BOOLEAN Whether or not the component will use class attributes for its left pen style.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:GetCompUseClassLPS

VS Functions: [[VS:GetCompUseClassLPS]]