VS:SetCompUseClassLPCl

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the use class pen colors for left pen flag of a component in an object.

FUNCTION SetCompUseClassLPCl(
object :HANDLE;
componentIndex :INTEGER;
useClassPenColorsForLeftPen :BOOLEAN) : BOOLEAN;
def vs.SetCompUseClassLPCl(object, componentIndex, useClassPenColorsForLeftPen):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
useClassPenColorsForLeftPen BOOLEAN Whether or not the component will use class attributes for its left pen colors.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:GetCompUseClassLPCl

VS Functions: [[VS:GetCompUseClassLPCl]]