VS:SetCompUseClassLPCl

From Vectorworks Developer
Revision as of 17:43, 16 September 2015 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the use class pen colors for left pen flag of a component in an object.

FUNCTION SetCompUseClassLPCl(
object :HANDLE;
componentIndex :INTEGER;
useClassPenColorsForLeftPen :BOOLEAN) : BOOLEAN;
def vs.SetCompUseClassLPCl(object, componentIndex, useClassPenColorsForLeftPen):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
useClassPenColorsForLeftPen BOOLEAN Whether or not the component will use class attributes for its left pen colors.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:GetCompUseClassLPCl

VS Functions: [[VS:GetCompUseClassLPCl]]