VS:SetCompPenStylesN

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the pen styles of a component in an object.

FUNCTION SetCompPenStylesN(
object :HANDLE;
componentIndex :INTEGER;
leftPenStyle :LONGINT;
rightPenStyle :LONGINT) : BOOLEAN;
def vs.SetCompPenStylesN(object, componentIndex, leftPenStyle, rightPenStyle):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
leftPenStyle LONGINT The left pen style of the component.
rightPenStyle LONGINT The right pen style of the component.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:GetCompPenStylesN

VS Functions: [[VS:GetCompPenStylesN]]