VS:SetCompMasterSnaps

From Vectorworks Developer
Revision as of 18:51, 7 December 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the master snaps of a component in an object.

FUNCTION SetCompMasterSnaps(
object :HANDLE;
componentIndex :INTEGER;
masterSnapOnLeft :BOOLEAN;
masterSnapOnRight :BOOLEAN) : BOOLEAN;
def vs.SetCompMasterSnaps(object, componentIndex, masterSnapOnLeft, masterSnapOnRight):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
masterSnapOnLeft BOOLEAN Whether or not the component has a master snap on its left.
masterSnapOnRight BOOLEAN Whether or not the component has a master snap on its right.

Version

Availability: from Vectorworks 2017

See Also

VS Functions:

VS:GetCompMasterSnaps

VS Functions: [[VS:GetCompMasterSnaps]]