VS:SetClassN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 19:25, 12 September 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetClassN assigns a class to the referenced object.

If the third parameter 'descIntoGroup' is set to true all objects within the group will receive the same class assignment as the group,
otherwise only the group itself will be affected.

PROCEDURE SetClassN(
h :HANDLE;
class :STRING;
descIntoGroup :BOOLEAN);
def vs.SetClassN(h, class, descIntoGroup):
    return None

Parameters

h HANDLE Handle to object.
class STRING Name of class to assign to object.
descIntoGroup BOOLEAN Assign the same class to all objects inside the group.

Example

PROCEDURE Example(h : Handle);
BEGIN
SetClassN(h, 'Class1', false);
END;
RUN(Example);

Version

Availability: from Vectorworks 2018

See Also

VS Functions:

VS:SetClass

VS Functions: [[VS:SetClass]]