VS:SetClassEndMarker

From Vectorworks Developer
Revision as of 14:37, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets all properties for the named class's end marker. Return TRUE if operation was successful.

FUNCTION SetClassEndMarker(
name :STRING;
style :LONGINT;
angle :INTEGER;
size :REAL;
width :REAL;
thicknessBasis :INTEGER;
thickness :REAL) : BOOLEAN;
def vs.SetClassEndMarker(name, style, angle, size, width, thicknessBasis, thickness):
    return BOOLEAN

Parameters

name STRING Name of the class.
style LONGINT The marker style. (see comments for details)
angle INTEGER The marker angle in degrees. (0 to 90)
size REAL The marker size in page inches.
width REAL The marker width in page inches.
thicknessBasis INTEGER The marker thickness basis. ( see comments for details)
thickness REAL The marker thickness.

Example

VectorScript

PROCEDURE Example;
VAR
ok : BOOLEAN;
BEGIN
ok := SetClassEndMarker('None', 1280, 25, 0.125, 0.125, 0, 2);
END;

RUN(Example);

Python


Version

Availability: from VectorWorks13.0

See Also

VS Functions:

VS:SetClassBeginningMarker

VS Functions: [[VS:SetClassBeginningMarker]]