VS:SetClassBeginningMarker

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets all properties for the named class' beginning marker. Return TRUE if operation was successful.

FUNCTION SetClassBeginningMarker(
name :STRING;
style :LONGINT;
angle :INTEGER;
size :REAL;
width :REAL;
thicknessBasis :INTEGER;
thickness :REAL) : BOOLEAN;
def vs.SetClassBeginningMarker(name, style, angle, size, width, thicknessBasis, thickness):
    return BOOLEAN

Parameters

name STRING Name of the class
style LONGINT The marker style (see comments for details)
angle INTEGER The marker angle in degrees (0 to 90)
size REAL The marker size in pages inches
width REAL The marker width in page inches
thicknessBasis INTEGER The marker thickness basis. ( see comments for details)
thickness REAL The marker thickness

Example

VectorScript

PROCEDURE Example;
VAR
ok : BOOLEAN;	
BEGIN
ok := SetClassBeginningMarker('None', 1280, 45, 0.25, 0.25, 0, 2);	
END;

RUN(Example);

Python


Version

Availability: from VectorWorks13.0

See Also

VS Functions:

VS:SetClassEndMarker

VS Functions: [[VS:SetClassEndMarker]]