VS:SetClass

From Vectorworks Developer
Revision as of 14:37, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetClass assigns a class to the referenced object.

PROCEDURE SetClass(
h :HANDLE;
class :STRING);
def vs.SetClass(h, class):
    return None

Parameters

h HANDLE Handle to object.
class STRING Name of class to assign to object.

Remarks

If you use SetClass to set the class of an object to the 'None' class, and the 'None' class has been renamed, there are two possible outcomes. If the user has renamed the 'None' class, and then created a new class named 'None' (bad idea, by the way), the class of the object will be set to 'None'. If there is not actually a class named 'None', the class of the object will be set to the original 'None' class, whatever it is named now.

Note that if a handle to group is used, all objects within the group will receive the same class assignment as the group [Julian].

Example

VectorScript

PROCEDURE Example;
BEGIN
SetClass(FSActLayer, 'None');
END;
RUN(Example);

Python


Version

Availability: from All Versions