VS:SetClPenFore

From Vectorworks Developer
Revision as of 21:39, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the pen foreground color of the specified class. The color must be specified using the RGB components of the desired color. RGB values are in the range of 0~65535.

PROCEDURE SetClPenFore(
className :STRING;
color :LONGINT);
def vs.SetClPenFore(className, color):
    return None

Parameters

className STRING Name of class.
color LONGINT RGB color value.

Remarks

Changes the pen foreground color setting of the class named className.

Example

VectorScript

ColorIndexToRGB(214,cRed,cGrn,cBlu);
SetClPenFore('Cold Water Supply',cRed,cGrn,cBlu);

Python


Version

Availability: from VectorWorks8.0