VS:SetClPenFore: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:37, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the pen foreground color of the specified class. The color must be specified using the RGB components of the desired color. RGB values are in the range of 0~65535.

PROCEDURE SetClPenFore(
className :STRING;
color :LONGINT);
def vs.SetClPenFore(className, color):
    return None

Parameters

className STRING Name of class.
color LONGINT RGB color value.

Remarks

Changes the pen foreground color setting of the class named className.

Example

VectorScript

ColorIndexToRGB(214,cRed,cGrn,cBlu);
SetClPenFore('Cold Water Supply',cRed,cGrn,cBlu);

Python


Version

Availability: from VectorWorks8.0