VS:SetClPenFore: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
(2 intermediate revisions by the same user not shown)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE SetClPenFore(className:STRING; color:LONGINT);
PROCEDURE SetClPenFore(className:STRING; r,g,b:LONGINT);
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.SetClPenFore(className, color):
def vs.SetClPenFore(className, r,g,b):
     return None
     return None
</funcDef>
</funcDef>

Latest revision as of 13:49, 26 April 2023

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the pen foreground color of the specified class. The color must be specified using the RGB components of the desired color. RGB values are in the range of 0~65535.

PROCEDURE SetClPenFore(
className :STRING;
r,g,b :LONGINT);
def vs.SetClPenFore(className, r,g,b):
    return None

Parameters

className STRING Name of class.
color LONGINT RGB color value.

Remarks

Changes the pen foreground color setting of the class named className.

Example

VectorScript

ColorIndexToRGB(214,cRed,cGrn,cBlu);
SetClPenFore('Cold Water Supply',cRed,cGrn,cBlu);

Python


Version

Availability: from VectorWorks8.0