VS:SetClFPat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:37, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the fill pattern of the specified class.

To apply a bitmap fill pattern, use a positive value corresponding to the desired fill pattern index. To apply a vector fill, use the negative of the index of the vector fill (index * -1).

Fill patterns and their associated constants can be found in the VectorScript Appendix.

PROCEDURE SetClFPat(
className :STRING;
fillpattern :LONGINT);
def vs.SetClFPat(className, fillpattern):
    return None

Parameters

className STRING Name of class.
fillpattern LONGINT Fill pattern index value.

Remarks

Assigns a fill pattern to the class named className.

Example

VectorScript

SetClFPat('Grassy Cover',42);

Python


Version

Availability: from VectorWorks8.0