VS:SetBelowItem

From Vectorworks Developer
Revision as of 14:37, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Places the specified control item below a previously inserted control item. Additional positioning can be performed by specifying x- and y-offsets (in pixels) from the initial insert position. Indent is in number of characters. LineSpacing is in pixels.

PROCEDURE SetBelowItem(
dialogID :LONGINT;
srcItemID :LONGINT;
belowtItemID :LONGINT;
indent :INTEGER;
lineSpacing :INTEGER);
def vs.SetBelowItem(dialogID, srcItemID, belowtItemID, indent, lineSpacing):
    return None

Parameters

dialogID LONGINT The index of the dialog layout being defined.
srcItemID LONGINT The index of the anchor control item.
belowtItemID LONGINT The index of the control item being placed.
indent INTEGER Left-right (x) control offset value.
lineSpacing INTEGER Up-down (y) control offset value.

Remarks

Use the indent and lineSpacing sparingly.[DWD 1/20/00]

Version

Availability: from VectorWorks9.0