VS:SetBatAttributes/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した屋根の中の、波形のドーマーを設定します。

PROCEDURE SetBatAttributes(
roofObject :HANDLE;
dormerID :INTEGER;
useHeight :BOOLEAN;
heightDepthValueDistance :REAL)Coordinate); bottomWidthDistance:REAL (Coordinate); topWidthDistance:REAL (Coordinate); baseHeightDistance:REAL (Coordinate); controlPointDistance:REAL (Coordinate); topAngle:REAL);
def vs.SetBatAttributes(roofObject, dormerID, useHeight, heightDepthValueDistance, bottomWidthDistance, topWidthDistance, baseHeightDistance, controlPointDistance, topAngle):
    return None

Parameters

roofObject HANDLE 屋根のハンドル
dormerID INTEGER ドーマーの番号
useHeight BOOLEAN 高さ設定の有無
heightDepthValueDistance REAL (Coordinate) 高さまたは厚み
bottomWidthDistance REAL (Coordinate) 下部の幅
topWidthDistance REAL (Coordinate) 上部の幅
baseHeightDistance REAL (Coordinate) 高さ
controlPointDistance REAL (Coordinate) 制御点の位置
topAngle REAL 傾斜角度

Example

roofHandle := CreateRoof(TRUE,5 1/2",5 1/2",4,9.52627");
AppendRoofEdge(roofHandle,-77'10",-25'3.18078",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",-25'3.18078",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",21'4.81922",#45°0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-77'10",21'4.81922",#45°0'0",2'0",10'0");
batID := CreateBatDormer(roofHandle);
SetBatAttributes(roofHandle,batID,TRUE,5'0",10'0",4'0",6'3",2'0",#8°0'0");
SetDormerAttributes(roofHandle,batID,3,18'4",TRUE,3'0",63,FALSE,3'0");
SetDormerThick(roofHandle, 2",1.83333");

Version

利用可能バージョン: VectorWorks8.0