VS:SetBatAttributes

From Vectorworks Developer
Revision as of 22:16, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetBatAttributes sets the attributes of a bat dormer in the referenced roof.

PROCEDURE SetBatAttributes(
roofObject :HANDLE;
dormerID :INTEGER;
useHeight :BOOLEAN;
heightDepthValueDistance :REAL;
bottomWidthDistance :REAL;
topWidthDistance :REAL;
baseHeightDistance :REAL;
controlPointDistance :REAL;
topAngle :REAL);
def vs.SetBatAttributes(roofObject, dormerID, useHeight, heightDepthValueDistance, bottomWidthDistance, topWidthDistance, baseHeightDistance, controlPointDistance, topAngle):
    return None

Parameters

roofObject HANDLE Handle to roof.
dormerID INTEGER Index of dormer element.
useHeight BOOLEAN Use height setting to create dormer element.
heightDepthValueDistance REAL Height/depth distance.
bottomWidthDistance REAL Bottom width.
topWidthDistance REAL Top width.
baseHeightDistance REAL Base height of bat.
controlPointDistance REAL Offset distance of control point.
topAngle REAL Slope of bat roof.

Remarks

dormerID: Identifies the dormer for which to set the information.

useHeight: Set to true if the next value is the height of the dormer, if false, next value is the depth (front to back) of the dormer. heightDepthValue: Size of the dormer, either by height or depth; determined by previous parameter.

bottomWidth: Dimension of bottom front edge of the dormer, left to right.. topWidth: Dimension of the roof of the dormer. baseHeight: Dimension of the bottom half of the dormer.

topSlope: Angle of the dormer roof.

controlPoint: The distance from the side to where the curve starts. Must be less than (bottomWidth - topWidth) / 2.

Example

VectorScript

roofHandle := CreateRoof(TRUE,5 1/2",5 1/2",4,9.52627");
AppendRoofEdge(roofHandle,-77'10",-25'3.18078",#45",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",-25'3.18078",#45",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",21'4.81922",#45",2'0",10'0");
AppendRoofEdge(roofHandle,-77'10",21'4.81922",#45",2'0",10'0");
batID := CreateBatDormer(roofHandle);
SetBatAttributes(roofHandle,batID,TRUE,5'0",10'0",4'0",6'3",2'0",#8");
SetDormerAttributes(roofHandle,batID,3,18'4",TRUE,3'0",63,FALSE,3'0");
SetDormerThick(roofHandle, 2",1.83333");

Python


Version

Availability: from VectorWorks8.0