VS:SetArc

From Vectorworks Developer
Revision as of 22:01, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetArc sets the start and sweep angles of the referenced arc or round wall object. Specify the angles in degrees.

PROCEDURE SetArc(
h :HANDLE;
startAngle :REAL;
arcAngle :REAL);
def vs.SetArc(h, startAngle, arcAngle):
    return None

Parameters

h HANDLE Handle to arc.
startAngle REAL New start angle of arc.
arcAngle REAL New sweep angle of arc.

Example

VectorScript

PROCEDURE GetArcSetArcExample;
VAR
h :HANDLE;
startAng, sweepAng :REAL;
BEGIN
h := FSActLayer;
GetArc(h, startAng, sweepAng);
SetArc(h, startAng, sweepAng + 10);
END;
RUN(GetArcSetArcExample);

Python


Version

Availability: from All Versions