VS:Set2DComponentGroup: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(fix table)
 
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Sets the specified 2D component group of a symbol definition or plug-in object.   Use Top/Plan if you want to add the group into the main container of the object.                                                                                                                   Table - 2D components<BR>
Sets the specified 2D component group of a symbol definition or plug-in object. Use Top/Plan if you want to add the group into the main container of the object.  
2D component Constant<BR>
 
Not Set 0<BR>
 
Top 1<BR>
''Table - 2D components''
Bottom 2<BR>
{| class = "wikitable_c"
Top and Bottom Cut                 3<BR>
! Constant !! 2D component
Front 4<BR>
|-
Back 5<BR>
| 0 || Not Set
Front and Back Cut                 6<BR>
|-
Left 7<BR>
| 1 || Top
Right 8<BR>
|-
Left and Right Cut                 9  <BR>
| 2 || Bottom
Top/Plan               10</desc>
|-
| 3 || Top and Bottom Cut
|-
| 4 || Front
|-
| 5 || Back
|-
| 6 || Front and Back Cut
|-
| 7 || Left
|-
| 8 || Right
|-
| 9  || Left and Right Cut  
|-
| 10  || Top/Plan
|}
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 05:46, 14 February 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the specified 2D component group of a symbol definition or plug-in object. Use Top/Plan if you want to add the group into the main container of the object.


Table - 2D components

Constant 2D component
0 Not Set
1 Top
2 Bottom
3 Top and Bottom Cut
4 Front
5 Back
6 Front and Back Cut
7 Left
8 Right
9 Left and Right Cut
10 Top/Plan
FUNCTION Set2DComponentGroup(
objectHandle :HANDLE;
groupHandle :HANDLE;
component :INTEGER) : BOOLEAN;
def vs.Set2DComponentGroup(objectHandle, groupHandle, component):
    return BOOLEAN

Parameters

objectHandle HANDLE Handle to the object.
groupHandle HANDLE Handle to the graphics group. Can be a group or a single object. To delete the corresponding group provide NULL.
component INTEGER 2D component.

Return Value

Returns TRUE if the operation was successful.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:Get2DComponentGroup

VS Functions: [[VS:Get2DComponentGroup]]