VS:Set2DComponentGroup: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(No difference)

Revision as of 22:36, 12 September 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the specified 2D component group of a symbol definition or plug-in object. Use Top/Plan if you want to add the group into the main container of the object. Table - 2D components

2D component Constant
Not Set 0
Top 1
Bottom 2
Top and Bottom Cut 3
Front 4
Back 5
Front and Back Cut 6
Left 7
Right 8
Left and Right Cut 9
Top/Plan 10

FUNCTION Set2DComponentGroup(
objectHandle :HANDLE;
groupHandle :HANDLE;
component :INTEGER) : BOOLEAN;
def vs.Set2DComponentGroup(objectHandle, groupHandle, component):
    return BOOLEAN

Parameters

objectHandle HANDLE Handle to the object.
groupHandle HANDLE Handle to the graphics group. Can be a group or a single object. To delete the corresponding group provide NULL.
component INTEGER 2D component.

Return Value

Returns TRUE if the operation was successful.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:Get2DComponentGroup

VS Functions: [[VS:Get2DComponentGroup]]