VS:SelectEditText: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
mNo edit summary
 
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Activates the given text component and selects its text.</desc>
Activates the given text component and selects its text.
[MaKro] Hint: Can be used to set the cursor at end of text when used in combination with VS:DeselectEditText
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 10:53, 16 October 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Activates the given text component and selects its text.

[MaKro] Hint: Can be used to set the cursor at end of text when used in combination with VS:DeselectEditText

PROCEDURE SelectEditText(
dialogID :LONGINT;
componentID :LONGINT);
def vs.SelectEditText(dialogID, componentID):
    return None

Parameters

dialogID LONGINT the dialog identifier given by CreateLayout or CreateResizableLayout
componentID LONGINT The identifier of the component that is to be activated and selected.

Version

Availability: from Vectorworks 2010