VS:SelectClassChoice: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:37, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Use to select the class option in a popup that ShowByClassChoice has been called on. This function must be called with FALSE param if the popup currently has the class selection and the script wishes to change to a non-class selection.

PROCEDURE SelectClassChoice(
dialogID :LONGINT;
componentID :LONGINT;
select :BOOLEAN);
def vs.SelectClassChoice(dialogID, componentID, select):
    return None

Parameters

dialogID LONGINT Id of the dialog
componentID LONGINT Id of the popup control
select BOOLEAN TRUE if setting by class or FALSE if programmatically restoring the value to a non-class setting after class setting was applied

Version

Availability: from Vectorworks 2012