VS:SelectChoice

From Vectorworks Developer
Revision as of 17:21, 21 August 2009 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the selection state of the given item in a control of choices.

PROCEDURE SelectChoice(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
selectState :BOOLEAN);
def vs.SelectChoice(dialogID, componentID, itemIndex, selectState):
    return None

Parameters

dialogID LONGINT the dialog identifier given by CreateLayout or CreateResizableLayout
componentID LONGINT The identifier for the component that contains the choices.
itemIndex INTEGER The index of the item to set the selection state for.
selectState BOOLEAN True if the item at the given index should be selected. False otherwise.

Version

Availability: from Vectorworks 2010