VS:SelectChoice: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:37, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the selection state of the given item in a control of choices.

PROCEDURE SelectChoice(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
selectState :BOOLEAN);
def vs.SelectChoice(dialogID, componentID, itemIndex, selectState):
    return None

Parameters

dialogID LONGINT the dialog identifier given by CreateLayout or CreateResizableLayout
componentID LONGINT The identifier for the component that contains the choices.
itemIndex INTEGER The index of the item to set the selection state for.
selectState BOOLEAN True if the item at the given index should be selected. False otherwise.

Version

Availability: from Vectorworks 2010