VS:SaveActiveDocument

From Vectorworks Developer
Revision as of 05:08, 30 December 2020 by CBM-c- (talk | contribs) (Transfer Orso to _c_)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Saves a file with out presenting dialogs

FUNCTION SaveActiveDocument(
filePath :STRING) : LONGINT;
def vs.SaveActiveDocument(filePath):
    return LONGINT

Parameters

filePath STRING

Remarks

(_c_, 2014.09.20): Introduced by VW 10 (not 2010!), made public for VW 2014. This is predestinated to usage with Applescript, since it's dialog-free. Probably created for that precise usage, since I am not aware of a single command in the main application that could be using it.

It corresponds to "save as" but without dialog. Saving on the same file path name doesn't work (returns -1), only if the file path is different (returns 0).

Example

PROCEDURE Test;
VAR
	temp_l	: LONGINT;
BEGIN
	{ save the current file in the application folder }
	temp_l := SaveActiveDocument(concat(getFolderPath(1), 'try.mcd'));
END;
Run(Test); { _c_ }

Version

Availability: from Vectorworks 2014