VS:SaveActiveDocument: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(add infos)
(3 intermediate revisions by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Saves the active document. Not implemented.
Saves a file with out presenting dialogs</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION SaveActiveDocument(filePath :STRING) :LONGINT;
FUNCTION SaveActiveDocument(filePath:STRING) : LONGINT;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 29: Line 28:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2014.09.20): Introduced by VW 10 (not 2010!), made public for VW 2014. This is predestinated to usage with Applescript, since it's dialog-free. Probably created for that precise usage, since I am not aware of a single command in the main application that could be using it.


It corresponds to "save as" but without dialog. Saving on the same file path name doesn't work (returns -1), only if the file path is different (returns 0).
</remark>
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample><code lang="pas">
PROCEDURE Test;
VAR
temp_l : LONGINT;
BEGIN
{ save the current file in the application folder }
temp_l := SaveActiveDocument(concat(getFolderPath(1), 'try.mcd'));
END;
Run(Test); { orso }</code>
</sample>


</sample>
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>


[[Category:VS Function Reference|SaveActiveDocument]]
[[Category:VS Function Reference|SaveActiveDocument]]
[[Category:VS Function Reference:Utility|SaveActiveDocument]]
[[Category:VS Function Reference:File I/O|SaveActiveDocument]]

Revision as of 02:58, 13 November 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Saves a file with out presenting dialogs

FUNCTION SaveActiveDocument(
filePath :STRING) : LONGINT;
def vs.SaveActiveDocument(filePath):
    return LONGINT

Parameters

filePath STRING

Remarks

(Orso, 2014.09.20): Introduced by VW 10 (not 2010!), made public for VW 2014. This is predestinated to usage with Applescript, since it's dialog-free. Probably created for that precise usage, since I am not aware of a single command in the main application that could be using it.

It corresponds to "save as" but without dialog. Saving on the same file path name doesn't work (returns -1), only if the file path is different (returns 0).

Example

PROCEDURE Test;
VAR
	temp_l	: LONGINT;
BEGIN
	{ save the current file in the application folder }
	temp_l := SaveActiveDocument(concat(getFolderPath(1), 'try.mcd'));
END;
Run(Test); { orso }

Version

Availability: from Vectorworks 2014