VS:RunLayoutDialogN

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Displays the specified dialog and initiates the dialog event loop. The dialog event loop is specified in a procedure subroutine that is passed as a parameter to the function.

FUNCTION RunLayoutDialogN(
dialogID :LONGINT;
callback :PROCEDURE;
enableContextualHelp :BOOLEAN) : LONGINT;
def vs.RunLayoutDialogN(dialogID, callback, enableContextualHelp):
    return LONGINT

Parameters

dialogID LONGINT The index of the dialog to be displayed.
callback PROCEDURE The event loop subroutine for the dialog.
enableContextualHelp BOOLEAN Determines whether or not contextual help is accessible

Return Value

Returns a LONGINT value indicating the button pressed to exit the dialog.

Version

Availability: from Vectorworks 2018