VS:Run

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Initiates the execution of a VectorScript command by signalling the VectorScript interpreter to execute the script source code.

The procedure takes a single parameter, which is the name of the VectorScript command as defined at the beginning of the source code listing.

PROCEDURE Run(
p :PROCEDURE);
def vs.Run(p):
    return None

Parameters

p PROCEDURE

Example

VectorScript

PROCEDURE Example;
BEGIN
Sysbeep;
Sysbeep;
Sysbeep;
END;
RUN(Example);

Python


Version

Availability: from All Versions