VS:Rpstr GetValueStr

From Vectorworks Developer
Revision as of 14:36, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get a string value from the VectorScript value repository.

FUNCTION Rpstr_GetValueStr(
name :STRING;
defaultValue :DYNARRAY[] of CHAR) : DYNARRAY[] of CHAR;
def vs.Rpstr_GetValueStr(name, defaultValue):
    return DYNARRAY[] of CHAR

Parameters

name STRING The name of the value.
defaultValue DYNARRAY[] of CHAR Default value if the name does not exist in the VectorScript value repository.

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:Rpstr_RemoveValues | VS:Rpstr_RemoveValue | VS:Rpstr_GetValueBool | VS:Rpstr_SetValueBool | VS:Rpstr_GetValueInt | VS:Rpstr_SetValueInt | VS:Rpstr_GetValueReal | VS:Rpstr_SetValueReal | VS:Rpstr_GetValueStr | VS:Rpstr_SetValueStr

VS Functions:

[[VS:Rpstr_RemoveValues]] | [[VS:Rpstr_RemoveValue]] | [[VS:Rpstr_GetValueBool]] | [[VS:Rpstr_SetValueBool]] | [[VS:Rpstr_GetValueInt]] | [[VS:Rpstr_SetValueInt]] | [[VS:Rpstr_GetValueReal]] | [[VS:Rpstr_SetValueReal]] | [[VS:Rpstr_GetValueStr]]

| [[VS:Rpstr_SetValueStr]]