VS:RoundWall/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

円弧の壁を作成します。

PROCEDURE RoundWall(
centerPt :REAL;
startPt :REAL;
endPt :REAL);
def vs.RoundWall(centerPt, startPt, endPt):
    return None

Parameters

centerPt REAL 壁の中心の座標
startPt REAL 壁の始点の座標
endPt REAL 壁の終点の座標

Example

PROCEDURE Example;
VAR
	x1, y1, x2, y2, x3, y3 :REAL;
	lineHandle :HANDLE;
BEGIN
	GetPt(x1, y1);
	GetPtL(x1, y1, x2, y2);
	MoveTo(x1, y1);
	LineTo(x2, y2);
	lineHandle := LNewObj;
	GetPtL(x2, y2, x3, y3);
	IF lineHandle <> NIL THEN DelObject(lineHandle);
	RoundWall(x1, y1, x2, y2, x3, y3);
END;
RUN(Example);

Version

利用可能バージョン: MiniCAD7.0

See Also

関連関数:

VS:Wall

関連関数: [[VS:Wall]]